Question about UMI Rear Suspension Installation - Impala Tech
Brakes & Suspension Conversion Questions & more

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-06-2011, 12:32 AM Thread Starter
 
 
Join Date: Oct 2011
Location: Elizabethtown Ky
Posts: 8
 
Question about UMI Rear Suspension Installation

Hello,
I am in the process of installing a set of UMI upper and lower control arms and a 12 bolt rearend into my 66 Impala. I just installed the lower comtrol arms about an hour ago, and I noticed that they had some side to side play in them with the bolts tightened fully. I don't have the rearend installed yet, and the arms are just hanging there. Is this normal, or do I have a problem? This is my first Impala and I have never worked on a rear suspension that uses a trackbar, so please forgive me if this is a stupid question. Thanks in advance for any help that you guys can provide.
powerpack is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-06-2011, 12:15 PM
Senior Member
 
Join Date: Aug 2011
Location: Alberta, Canada
Posts: 224
 
Quote:
Originally Posted by powerpack View Post
Hello,
I am in the process of installing a set of UMI upper and lower control arms and a 12 bolt rearend into my 66 Impala. I just installed the lower comtrol arms about an hour ago, and I noticed that they had some side to side play in them with the bolts tightened fully. I don't have the rearend installed yet, and the arms are just hanging there. Is this normal, or do I have a problem? This is my first Impala and I have never worked on a rear suspension that uses a trackbar, so please forgive me if this is a stupid question. Thanks in advance for any help that you guys can provide.
This sounds normal. If there is no play at all, you're more likely to get binding as your rear end tried to move. This play in the lower arms is not significant as you have to look at the whole system together, with all components in place.
05snopro440 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome