HVAC issues - Impala Tech
Heating & Cooling Heating, cooling & air conditioning

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-12-2019, 12:03 AM Thread Starter
 
 
Join Date: Sep 2019
Posts: 2
 
HVAC issues

I have a 2008 Impala LT sedan. Recently, when we run the air conditioning, the passenger side blows really cold air while the drivers side blows hot air. Adjusting the driver control changes nothing. When I have the key on, engine off, I can operate the controls for each blend door and can hear the doors moving back and forth with no clicking. I did replace the passenger side blend door actuator about a year or so ago, but it was clicking almost all the time. Just wondering if replacing the driver side blend door actuator is the fix or is there something else I should be checking out. Please help.
chucknmesa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome