65 327 voltage issue - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-13-2020, 07:26 PM Thread Starter
 
 
Join Date: Aug 2012
Location: Boston MA.
Posts: 21
 
65 327 voltage issue

I have a 327 that was rebuilt two years ago and last year I changed the alternator, checked the battery and have 13amps on the meter. I am assuming its the voltage regulator thats causing my volt meter in the car to ping at 16. Just cant find the voltage regulator on my car.... thanks for any advice....
Attached Thumbnails
Click image for larger version

Name:	IMG_6735.jpg
Views:	15
Size:	53.2 KB
ID:	23792  

Last edited by cjophoto; 07-13-2020 at 09:20 PM. Reason: typo
cjophoto is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-13-2020, 10:47 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,925
 
With a volt meter or a multi meter set on DC voltage Touch the black lead to the negative terminal on the battery and the red lead to the big wire on the back of the alternator. If it is at 16 volts your "Internal" transistorized voltage regulator is shorted out and needs replacing. If you don't want to tear the alternator apart to replace the regulator module (it is that big hunk or aluminum fined metal inside the case you see in the back window of the alternator case); you can buy a replacement from your corner auto parts store.

Be sure to disconnect the battery before you work on any part of your cars wiring or electrical devices. Once the "sacred smoke" gets out it can not be put back in again.

Big Dave
Big Dave is offline  
post #3 of 8 (permalink) Old 07-14-2020, 12:21 AM
Senior Member
 
Join Date: Apr 2013
Location: Canada
Posts: 356
 
Quote:
Originally Posted by cjophoto View Post
I have a 327 that was rebuilt two years ago and last year I changed the alternator, checked the battery and have 13amps on the meter. I am assuming its the voltage regulator thats causing my volt meter in the car to ping at 16. Just cant find the voltage regulator on my car.... thanks for any advice....
Is it the original alternator/regulator setup? If so, I believe it's on the inside of the radiator support, kind of behind/beside the back of the driver's side headlights. It will have a flat 4 wire connector about 2" wide that plugs into it.
Darth is offline  
 
post #4 of 8 (permalink) Old 07-14-2020, 03:06 AM
Moderator
 
Join Date: Jan 2006
Posts: 12,925
 
Sorry Darth is correct 1963 to 74 was externally regulated with a mechanical voltage regulator mounted to the radiator core support.

Most people replace it with an internally regulated alternator (SI 37 to 63 Amp) and toss the troublesome mechanical one in the trash.

Actually most replace the alternator with a one wire CS alternator because it out puts enough amperage (105 to 160 Amps) to run the car, instead of being just an on board battery charger, and the car runs off the battery all the time.

Was thinking the voltage regulator change took place in 1967 but that was two years early and the change started in Olds and Cadillac cars, before finally coming to Chevy in '74.

Big Dave
Big Dave is offline  
post #5 of 8 (permalink) Old 07-14-2020, 06:06 PM
Senior Member
 
Join Date: Oct 2009
Location: Orange, CA
Posts: 1,386
Blog Entries: 34
 
Garage
This is on a 64 Impala, but probably the same regulator setup:
Attached Thumbnails
Click image for larger version

Name:	IMG_2661a.jpg
Views:	15
Size:	48.3 KB
ID:	23794  

1964 Impala 4 door sedan

My Bloggy Thing: http://www.impalas.net/forums/blog.php?u=2285
dcairns is offline  
post #6 of 8 (permalink) Old 07-15-2020, 08:27 PM
 
 
Join Date: Apr 2019
Posts: 7
 
Garage
Big Dave, do you know if you make a change to a CS alternator from stock as you mentioned do you have to upgrade the wiring also to a bigger gage? This would seem like a big job. Thanks!
Jim Trucksis is offline  
post #7 of 8 (permalink) Old 07-15-2020, 10:44 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,925
 
If you have not added any electrical loads that were not on the car when it was made no you don't. BUT, electric fans, 30 Amps; Electric Fuel pumps 20 Amps; Electric Water Pumps 6 Amps, or if you add electric windows, or a booming AMP for your stereo you would need to upgrade the wiring to handle the added load.

Even though the alternator out puts up to 160 Amps doesn't mean it is going todo so if there is no load looking for power. That is why the factory went to an alternator instead of a generator. An alternator only produces power if their is a need. Generators always out put max power rated: and can cook a battery if there is no load to consume that power being produced.

Big Dave
Big Dave is offline  
post #8 of 8 (permalink) Old 07-16-2020, 10:09 AM
Senior Member
 
Join Date: Jan 2018
Location: Coopersville, MI
Posts: 383
 
Quote:
Originally Posted by Big Dave View Post
....That is why the factory went to an alternator instead of a generator. An alternator only produces power if their is a need. Generators always out put max power rated: and can cook a battery if there is no load to consume that power being produced.

Big Dave
The swap was supposedly done in the beginning of 1963, but this actually resulted in some 63 impala's running generators while others got alternators. Of course this can cause some confusion to parts counter clerks as most parts computers list all 63 impalas as having an alternator.

1963 Impala Convertible (Frame off resto-mod in progress)
1963 Impala 2 door hardtop (Pro Street build in progress)
1963 Impala 4 door hardtop (Parts car)
Deadwolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome