66 Dash lights not working... - Impala Tech
Restoration Corner Aimed at Originality

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 08-20-2020, 12:20 PM Thread Starter
 
 
Join Date: Apr 2019
Posts: 18
 
66 Dash lights not working...

Hi...Replaced the headlight switch and got all the lights , exterior, working except for back up lights.

I have no dash lights when I turn on the headlight switch, but turn signals, high beam, indicators work.

Any help on where to start looking appreciated....
HalnasLT1 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-20-2020, 12:51 PM
Moderator
 
Join Date: Jan 2006
Posts: 13,023
 
Have you checked the fuse box?

Whenever you are working on your electrical system you should always disconnect the negative terminal at the battery and only reconnect it after checking your circuits with a multi-meter first.

Big dave
Big Dave is offline  
post #3 of 7 (permalink) Old 08-20-2020, 04:53 PM Thread Starter
 
 
Join Date: Apr 2019
Posts: 18
 
Hi Dave.... God idea, but the dash is in the car already. I'm restoring it and need the dash lights to work for the safety certificate.

There are some gauges under the dash and the lights work on them. Was hoping for a "clue" on where to start and if this is a common issue. Could it be the circuit board on the speedo cluster?

TIA
HalnasLT1 is offline  
 
post #4 of 7 (permalink) Old 08-22-2020, 08:35 AM
Member
 
Join Date: Jan 2019
Location: PA
Posts: 47
 
Garage
Are you sure they're not just turned all the way down? If they aren't, the feed for the dash lights on the light switch is faulty or not in the right place.

Craig

66 Impala (in progress)
56 stepside shortbed
55 Bel Air sedan
81 Corvette
02 Monte Carlo (bought new)
craig32 is offline  
post #5 of 7 (permalink) Old 08-22-2020, 10:30 AM Thread Starter
 
 
Join Date: Apr 2019
Posts: 18
 
I installed new headlight switch, that fixed no tailights/signals and courtesy light staying on. There are aftermarket gauges with lights under the dash, they work and I can see the brightness change when the switch is turned...

THX
HalnasLT1 is offline  
post #6 of 7 (permalink) Old 09-02-2020, 10:46 PM
 
 
Join Date: Aug 2020
Posts: 8
 
Good to know. Where did you get the new switch?
dreison12 is offline  
post #7 of 7 (permalink) Old 09-02-2020, 11:04 PM Thread Starter
 
 
Join Date: Apr 2019
Posts: 18
 
Hi.... Got everything figured out. Been along time since I had an old car. Had the headlight turned down thinking it was going to be brighter turning it down, main reason was there no ground to the cluster. Ran a jumper wire and lights on 8 of the 12 sockets. Need a circuit board which I found on Ebay. Should fix my problems....

Dreison12.... rock auto, napa, still readiy available


Thx Guys for trying to help
HalnasLT1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome