Impala Tech - Reply to Topic
Electrical & Wiring Troubleshooting electrical problems

Thread: Headlamps turning off when Hi-Beam engaged Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-07-2019 03:14 PM
kiwidave UPDATE:

Just thought I'd post that I cleaned the footswitch and connector with Electrical Cleaner and an old toothbrush, let it dry and it's working fine.
Hopefully I don't have trouble with the Xeon bulb drawing too much power as B.A mentioned but for now all good.

Thanks for your help!
05-25-2019 12:17 PM
bicster Good point Dave. 40 years ago I experienced the same problem with a car I had and it ended up being the high beam/low beam switch on the floor. If the new head light switch doesn't fix it try the switch in the floor.
05-23-2019 05:04 PM
BA. I'm not disagreeing with Dave here, not at all. Those old switches get troublesome with age....but,

Excuse my ignorance or presumption here but wouldn't/shouldn't a Xenon bulb use a breaker near the headlight with its' own 12v source so that the extra wattage doesn't flow through the 50 yr old wiring?
05-23-2019 10:52 AM
Big Dave Bad switch. They get full of dirt and the contacts are blocked as well as being under a heavy electrical load when they work resulting in pitting and burning.

Big Dave
05-23-2019 10:31 AM
kiwidave
Headlamps turning off when Hi-Beam engaged

Interesting one.

I recently replaced my old Hi-Beam headlamps after one of my old ones died with 5-3/4'' Xenon Conversion Headlamp Bulb (High Beam).
Put them in, switched on and aligned them and all was good.
When I finally got around to driving and needing them I engaged the Hi-Beam footswitch and all of the headlamps went out! Not great considering I was driving at the time.
After I disengaged the Hi-Beam switch my main headlamps came back on.
The only difference I can see is the replacements have three pins rather than two but they worked fine when I first put them in, hence why I was able to align them.

Thoughts?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome