Impala Tech - Reply to Topic
Welcome Forum New to the site? Introduce yourself.

Thread: Hi everybody! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-22-2019 05:30 AM
carid Hello and welcome to the forum! Congrats on your Impala, show it to us when you get a chance. There are so many owners on this site that if you ever need help or advise on anything, someone will have the answers. Enjoy your new ride and your time here!
08-08-2019 03:40 PM
BA. Welcome to the site!


great name.
08-08-2019 11:34 AM
Big Dave Welcome to the Team!

Big Dave
08-07-2019 10:55 PM
Coondog
Hi everybody!

Brand new here. Just bought a 1970 Impala a few weeks back. Really looking forward to talking with everyone and getting some knowledge from you.
It has a SBC 350 made in Flint, April 1972. Previous owner hopped up the engine a little. Aftermarket cam, headers, intake , carb. TH350, 12bolt rearend. It runs pretty good. Water temp guage isnt hooked up but that's an easy one. Anyway, wanted to say hello before I get into the question section. Take care.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome