Impala Tech - Reply to Topic
Electrical & Wiring Troubleshooting electrical problems

Thread: Looking for 1965 ignition switch Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-25-2017 10:33 AM
Big Dave Check voltages from the battery to the back of the fuse block, then check again on the front of the fuse block. From the fuse block check to the back of the ignition switch, and from the switch to the terminal on the solenoid. If the battery has only five volts it is dead.

There are fusible links in the primary wiring that could have blown, there could be corrosion where the fuse block bolts together causing excessive resistance, and there are fusilble links as well as fusses in the secondary wiring.

The factory wiring was inadequate for the loads in the car when it was first built. GM is famous for being cheap and copper has always been an expensive metal. It has gotten even more expensive today as we have depleted all of the readily accessible copper ore on the planet.

Copper corrodes (turns green) with age which causes resistance in wiring terminals. Additionally it easily work hardens, so vibrations cause the wire strands to crack, which results in fewer and fewer strands of copper trying to support the electrical load (which were too few to start with). This reduced wire gage can cause an electrical fire as the load heats the few remaining strands to incandescence.

I have no interest in restoring a car to factory specs; I would rather enjoy my cars so I yank out the factory wiring and replace it with a 12 fuse Painless 14 gage (or heavier gage depending upon the circuit) wire set along with a Modern CS (one wire) alternator rated at 160 to 200 Amps to handle any load that I might have.

By doing this I not only maintain a constant voltage at all times and engine speeds with the one wire alternator that powers the car, but I have nearly doubled the size of the wiring to handle the electrical loads and reduce voltage drop per linear foot with the heavier gage wires.

Your SI style alternator was rated at only 36, 45, or 63 Amps max at 3,600 RPM and was nothing more than an on board battery charger; with all electrical loads being running off the battery draining it faster than it could be recharged. this is why your lights dim at a stop sign and your wipers stop working at night in the rain. (I need more power Mr. Scott!)

Big Dave
11-24-2017 11:57 PM
Houston Update:
I got the EL2308Z from "The Parts Place" and the terminals are the same as my 65 SS.

But I'm only getting 5v from the ignition switch to the starter. Any ideas on what could be the issue here?
11-15-2017 03:46 PM
Big Dave It was used in all GM cars back then. The only difference in part numbers has to do with pin outs in addition to the ignition. Some had a built in light that illuminated with the dash lights, and others had a timer to turn off accessories before the battery died. But all had the the basic on-off Ignition and Accs function, and fit in the same size hole in the dash.

Big Dave
11-15-2017 03:33 PM
Axsom It seems to cross with the Corvette???
11-15-2017 02:21 PM
Houston So, Hubbard's is backordered. Called and confirmed that "The Parts Place" has this is stock. Order placed.

I'll let y'all know how this turns out.


Axsom: Thanks, I'll keep monitoring there also.


I did find another 1116660 for $125 (plus shipping)

.
11-15-2017 02:05 PM
Axsom Google search- GM 1116660 and there is a Ď65 Buick one one EBay ???
11-15-2017 09:40 AM
Houston Looks like Delco- #1116649 is for a 64 GM from general search results.

Does anyone know what the difference is between the 64, 65, 66 and 67 ignition switches?

Is it something I can modify and make it work?


.
11-15-2017 09:28 AM
Houston
Quote:
Originally Posted by Darth View Post
It's part of it! The GM number for the switch is 1116660.
AWESOME! Thanks!

Any chance you would know what a Delco- #1116649 might fit?


Is there a website reference for part-number look-up?
11-15-2017 12:10 AM
Darth
Quote:
Originally Posted by Houston View Post


I can't seem to find a part number other than "660", but I'm doubting that's the part number.
It's part of it! The GM number for the switch is 1116660.
11-14-2017 09:37 PM
Houston
Quote:
Originally Posted by Big Dave View Post
Welcome to the Team!
Thank you, Big Dave!

Quote:
Originally Posted by Big Dave View Post
This may fit. Be sure to compare it with what you have now to be sure: There are a few other ignition switches offered for sale as well as this one.
The one in that ebay ad looks to be a 4-terminal switch with the lamp housing. Mine seems to be a 5-terminal.


I can't seem to find a part number other than "660", but I'm doubting that's the part number. Would you have any advice there?

.
11-14-2017 09:32 PM
Houston
Quote:
Originally Posted by Axsom View Post
Try The Parts Place Inc
They do have one - part number EL2308Z - (sorry, I can't provide a URL to the description)

It looks like the exact same as what I found at Hubbard's.
11-14-2017 09:03 PM
Big Dave Welcome to the Team!

This may fit. Be sure to compare it with what you have now to be sure: There are a few other ignition switches offered for sale as well as this one.

https://www.ebay.com/p/Delco-Remy-D1....c100005.m1851

Big Dave
11-14-2017 09:00 PM
Axsom Try The Parts Place Inc
11-14-2017 07:25 PM
Houston
Looking for 1965 ignition switch

Hello Team Impala,

I'm new to this forum, so please guide me... I searched in the forum and did not find what I'm looking for.

I need to replace the ignition switch on my 1965 SS. (see pics of my switch attached)

Classic Industries does not carry one for 65 or 66. H&H lists 67 and later. Bob's Impala doesn't even list ignition switches.

The only one I can find is this one from Hubbard's Impala Parts:
https://www.impalaparts.com/65IS/

The photo does not look like the one I have. Does anyone have experience with that switch from Hubbard's?

Or... is there any other good, stock replacement options available?

Thanks for your help. Looking to put a 65 back on the road after a long sleep.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome