Impala Tech - Reply to Topic
Electrical & Wiring Troubleshooting electrical problems

Thread: 1966 Impala Ignition Switch Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-21-2019 02:02 PM
Big Dave
Quote:
Originally Posted by lndbarron View Post
yes, if i disconnect the positive terminal car stays running. disconnecting the battery maintains a charge
You are playing with fire (literally) if you disconnect any positive terminal with the engine running. A fraction of a second contact with any body part gets a big spark followed by old west Indian smoke signals that state ("Kiss your fuseable link good bye").

Any electrical work done on a car should be with the battery disconnected and the ignition switch off (unless you are testing the circuit). You use meters (some are self powered with a nine volt or a 1.2 volt batter). Best tool I have found is this Chinese copy of a KD (which is a Korean copy of a Fluke) tester:

https://www.amazon.com/dp/B071LHLSBB...v_ov_lig_dp_it

Big Dave
05-21-2019 01:10 PM
japete92 This may be helpful:

https://www.americanautowire.com/vie...ectrical-draw/


Pete
05-20-2019 07:29 PM
lndbarron yes, if i disconnect the positive terminal car stays running. disconnecting the battery maintains a charge
05-12-2019 06:37 PM
marsmann
Quote:
Originally Posted by fsc66 View Post
That is correct, they have 4 positions

Paul
Apologies for any confusion. I see it was poorly worded. I am counting positions from left to right from off to crank.

To the original poster, since you have replaced your switch and regulator, have you eliminated the alternator?
05-12-2019 06:02 PM
lndbarron Thanks everyone for responses, I have changed a factory correct ignition switch, and the voltage regulator. However the battery still is not maintaining charge. I have checked the battery and all tests are saying it is a good battery. When I jump the car there is a clicking in the voltage regulator when I and connecting the jumper cables. I cannot figure out why the battery will not maintain a charge. Any ideas?
04-29-2019 09:18 AM
fsc66 That is correct, they have 4 positions

Paul
04-29-2019 01:12 AM
Darth
Quote:
Originally Posted by marsmann View Post
The 66, as you know, has three positions only. Off, On, Start.
As far as I've ever seen, all 66 full size Chevy ignition switches have ACC, OFF, ON and START.
04-28-2019 10:14 PM
marsmann If I understood these posts correctly, is there a chance that your 66 was retrofitted with a 68 style switch? The 66, as you know, has three positions only. Off, On, Start. If your switch is original or the correct part for your 66, then it is most likely defective and the 'in-between' setting is making contact with the start circuit, thereby consuming battery or causing a parasitic type drain.
04-26-2019 07:11 PM
bigears That's interesting similar issue here however a 68 not 66 only found out on a flat battery.
There are four positions on the 68 and the off position is between ACC & ON is a hard find not a positive feel .....
Now as pointed out by Big Dave (worn out) I know mine is the original key tells the story and the fact
the complete barrel comes out when in the ACC position that however ended up a bonus as the key number is on
the back of the barrel. That enabled the key cutting shop to produce a key that worked previous attempts off the
original failed. So until I need or find a vendor for replacement ignitions I found a switch on the battery a big help
be a pain if driven daily but works for me ........
04-26-2019 11:13 AM
Big Dave Sounds defective (worn out) to me.

Big Dave
04-25-2019 10:29 PM
lndbarron
1966 Impala Ignition Switch

I need some help to confirm the serviceability of my ignition switch. How many positions should be on switch i.e accessory key completely left. Off straight up and down. Run key completely right. My switch has a position in between off and accessory is this correct?
I have been having trouble keeping battery charged I sense the ignition switch is not completely shutting off. How can I determine if the switch is completely turning off? By the way all lights and gauges turn off.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome