Impala Tech - Reply to Topic
Convertibles Convertible Q&A's

Thread: advice on new pump and cylinders for 67 vert Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-15-2019 02:19 PM
67ImpalaSSConv
Quote:
Originally Posted by 68WASAGOODYEAR View Post
I HIGHLY recommend changing the lines while you have everything apart. They are not that expensive, and if you have the OEM ones, at 50+ years old they are brittle and ready to leak. Mine literally fell apart when I touched them, spilling brake fluid everywhere. Just FYI.
So I did get the hydraulics working good. Ordered a new Lares pump, it works great (mostly).

My bleeding technique was to do it on the floor. install the cylinders and leave the two pump connectors in a bucket of ATF, and then pull the cylinders back and forth (was hard) while sucking up fluid and shaking the cylinders to get all the bubbles out. It worked well. Then I filled the new pump and connected the fittings and worked it back and forth with a battery and check the fluid level. It worked like a charm.

Finally installed into the car intact and didn't have to remove hoses. Just loosed one slightly to rotate a hose.

My only problem now is that I only replaced one cylinder because it was damaged. I didn't anticipate what would happen. The old cylinder works fine, but is noticeably easier to move. So one side goes quite a bit faster and the top goes up uneven. Not sure if the new cylinder will wear in and even out eventually, or if it will cause any problems. If you stop it for a second they even out. But I'd have replaced both if I had thought about that issue.

Lesson learned..
10-08-2019 12:50 PM
68WASAGOODYEAR I HIGHLY recommend changing the lines while you have everything apart. They are not that expensive, and if you have the OEM ones, at 50+ years old they are brittle and ready to leak. Mine literally fell apart when I touched them, spilling brake fluid everywhere. Just FYI.
10-08-2019 12:05 PM
67ImpalaSSConv
Quote:
Originally Posted by 68WASAGOODYEAR View Post
I went through these guys when I replaced all of the convertible stuff in my 68:

https://store.convertibleparts.com/

Their service is outstanding and I think they manufacture their pumps, so you're not paying a middle man.

There is a 30 amp circuit breaker on the firewall that might be your problem. Follow the 12 ga. orange circuit through the firewall.

My advice is to replace everything, including the brake fluid they used from the factory. Replace it with ATF. If you skimp now, you'll just end up with leaks and /or a top that doesn't work when you need it to (like during a rain storm).
Thanks for the tips. I actually ordered a Lares pump just because the warranty is lifetime, and they were slightly cheaper. I have had good luck with their other parts I've used so far. We'll see..

As far as the breaker. I was actually bench bleeding the whole system directly from a battery. The motor was still shutting off after 15 seconds or so and was getting really hot. Even when it was full of fluid. It also wasn't moving the cylinders much after a while. I fear something went wrong in the pump and not sure they can be rebuilt.

I'm debating replacing everything while I'm at it. Cylinders seem to work but aren't that expensive ($100 ish each). I might reuse the hose just because I've read that some replacements aren't the right length. And mine is still flexible and in good shape. I'll clean it good first.

I'll update with results.
10-07-2019 03:39 PM
68WASAGOODYEAR I went through these guys when I replaced all of the convertible stuff in my 68:

https://store.convertibleparts.com/

Their service is outstanding and I think they manufacture their pumps, so you're not paying a middle man.

There is a 30 amp circuit breaker on the firewall that might be your problem. Follow the 12 ga. orange circuit through the firewall.

My advice is to replace everything, including the brake fluid they used from the factory. Replace it with ATF. If you skimp now, you'll just end up with leaks and /or a top that doesn't work when you need it to (like during a rain storm).
10-07-2019 03:00 PM
67ImpalaSSConv Good advice. I've went ahead and ordered a new lares motor, it had a better warranty than the others.

I do have it all apart. I was testing the whole setup on the bench and bleeding it, and the motor cuts out after 15 seconds running directly off the battery. So that eliminates the breaker. It probably has an internal thermal breaker or something. being 50 years old it probably needs replaced anyway.
10-07-2019 02:38 PM
japete92
Quote:
Originally Posted by 67ImpalaSSConv View Post
I was installing a used pump for my convertible top and discovered it is not working well. It runs for about 15 seconds and kicks off. I'm guess it has a thermal overload and is not worth fixing??

Question is, can this be easily repaired or should I just get a new one? Next question, Lares and AutoPro have about the same price. Which is better quality? Lares has a lifetime warranty although I don't have any experience with them. AutoPro has a 5 year warranty.

Also, I need 1 cylinder because one of mine has a small dent & you can feel it slightly catching. It works but I'm afraid to put it in and have a leak later on. Should I just replace both cylinders plus the hoses? My hoses are fine although are 50+ years old. I don't have any convertible experience to speak of prior to this.

Any advice? Thanks!

I don't have the wiring diagram for a '67; I have a '63. On my '63 there is a self resetting circuit breaker (40 amp as I remember) in the 'top' circuit (on the '63 it's located behind the driver's kick panel). Your breaker (if you have one) MAY be tripping. Lots of reasons why; including the motor, wiring, the breaker, etc. A little trouble shooting MIGHT save you some un-necessary expense.

IF the interior is 'apart', with ready access to all the lines and cylinders, I'd replace everything.

Pete
10-07-2019 10:47 AM
67ImpalaSSConv
advice on new pump and cylinders for 67 vert

I was installing a used pump for my convertible top and discovered it is not working well. It runs for about 15 seconds and kicks off. I'm guess it has a thermal overload and is not worth fixing??

Question is, can this be easily repaired or should I just get a new one? Next question, Lares and AutoPro have about the same price. Which is better quality? Lares has a lifetime warranty although I don't have any experience with them. AutoPro has a 5 year warranty.

Also, I need 1 cylinder because one of mine has a small dent & you can feel it slightly catching. It works but I'm afraid to put it in and have a leak later on. Should I just replace both cylinders plus the hoses? My hoses are fine although are 50+ years old. I don't have any convertible experience to speak of prior to this.

Any advice? Thanks!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome