Impala Tech - Reply to Topic
Electrical & Wiring Troubleshooting electrical problems

Thread: No tail light and no brake lights 1966 impala Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-19-2010 06:48 PM
Big Dave If you have turn signals then I suspect you have a problem with your brake light switch attached to the brake pedal. Plunge it in and out to see if your brake lights work. If that fixes your brake light problem you can turn the two nuts on the plastic threads of the switch to adjust it's operation.

Your tail lights are probably a result of a bad light switch (the contacts inside he switch wear down with age). However if the lights work up front but not in the back then I suspect it is a rear wire harness problem that you are facing.

Big Dave
06-19-2010 06:37 PM
Kandy66 I figured it out The fuse wasn't making a good connection!
06-19-2010 06:12 PM
Kandy66
No tail light and no brake lights 1966 impala

Whats up guys i have a 1966 impala and the brake lights and tail lights just stopped working i have checked everything and im lost now.But the turn singles still work. thanks for any info

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome