Impala Tech - Reply to Topic
Transmission & Driveline Transmissions & Differentials

Thread: '63 Impala drive shaft busted fuel line... Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-05-2013 08:57 PM
Goldie63 Thanks Guys, I love this forum.

I hope I can repay the favor of imparting info sometime.

~Steve
04-02-2013 09:10 AM
Txbobcat You were lucky. It could have come up thru the floorboard and ended your sexlife
04-01-2013 07:34 PM
Big Dave Your carrier bearing failed. Your car is half a century old parts wear out.

Beware of cheap corner auto parts store replacement carrier bearings which are made over seas (specifically the Pacific Ocean and most of the Indian Ocean). They will not last years never mind the decades that the Factory original lasted. Some are replaced within months of installing their first carrier bearing. The local auto parts store will cheerfully give you another cheap replacement when you bring it back complaining, however they will not reimburse the labor to install it over and over again.

http://www.summitracing.com/parts/ie...63?prefilter=1

Big Dave
04-01-2013 06:57 PM
Goldie63
'63 Impala drive shaft busted fuel line...

I have a '63 Impala 327 powerglide. In the middle of the central tunnel of the x-frame, apparently my drive shaft became loosened and was knocking around. While it was knocking around it busted my fuel line right in the middle of the X.

Any Ideas why this happened?

Thanks in advance!

~Steve

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome