Impalas.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I checked the fuses, cleaned the fuse panel block front and back. Bulbs are new.
The backup lights work fine as does both front T S's. No power to the right 2 T S lights as mentioned.
No dash lights..New switch. Yes I turned the knob. Where is the ground wire located on the damn dash panel?? I have 2 factory manuals and it is not shown. Such fun seeing the car sitting in the garage.. :angry:
Al 1965 SS
 

·
Registered
Joined
·
1,274 Posts
Often the contacts behind the bulbs are corroded. Try cleaning them and put a test light on it to be sure you have power to them.
 

·
Registered
Joined
·
9 Posts
hi. have you checked the harness in the trunk where it plugs in? it runs from the fuse panel to the back seat and thru the back panel in the trunk should be a harness plug. at the inside trunk lid the harness wiring runs from dash to rear of car under rug in the long plastic strip, forget what it is called, anyway you can open it and your wiring will be in there, can check and see if any breaks in wires or burnt or shorting wires which would cause no dash lights. also a defective high beam switch will give you problems not having dash lights. then test your wiring in the trunk at the sockets not working and trace your way back to the front, checking the harness plug in the trunk and wires in the plastic covering. also check your taillight wires from the left to the right rear inside the trunk lid if im not mistaken you get power from the left side to work the right side taillights, brakelights and running as well as signals. hope I helped you a little bit.
 

·
Super Moderator
Joined
·
2,916 Posts
I fought with my taillights for years. Always at least one not working. Bad grounds, Bad sockets. I finally got fedup and replaced them with LED's and cut out the sockets. Haven't had to touch them in 2 years.
 

Attachments

·
Registered
Joined
·
72 Posts
The '65's are notorious for having lousy ground connections in the sockets to the socket housing in the trunk lid and quarter panel extension. They have to be fully seated in order for the light to have a good ground and function. A $10 circuit test light is your best friend when working with 50 year old cars and their wiring. Use it find out where the bad connection is causing the right side tail lights not to work. ( A hint here. If one tail light is working, your fuse is not burnt. Look elsewhere. )

Turn on the lights, use the test light to see if you power to the light sockets. The right side have a green wire and a brown wire. Can't remember which one is brake/turn signal and which one is tail lamp. But, the test light should light up. If not start working back towards the tape wire harness that goes under the seats and carpet. Most likely your bad connection is before that.

I finally gave up on the '65 era light sockets and got a bunch for a '73 Monte Carlo because that era use a ground wire instead trying to ground the socket itself. No problems since. Also, make sure you have the dual element # 1157 bulbs.
 

·
Registered
Joined
·
8 Posts
You said a new switch, were you referring to the turn signal switch/ If not you might want to check the turn signal switch as well.
 

·
Registered
Joined
·
287 Posts
I had a 65 years ago that had taillight issues. The blinker would get stuck, move fast, or not at all. It also blew the fuse like no tomorrow. I ended up buying new sockets, and sanding the metal on the hood that houses them, problem solved.
 

·
Registered
Joined
·
6 Posts
Turn signal switch

I had the same symptoms on my 65. Actually if I read the wiring diagram right, the brake light wires run through the turn signal switch. I found my turn signal was bad just for the left rear brake and turn signal contacts. I ran a wire straight from the brake pedal switch to the wire going to the left rear brake light wire. Then, for the turn signal I ran a wire from the front signal wire to the rear signal wire. You have to use a diode the prevent the brake light switch from lighting the front turn signal. Diode cost a dollar. This is a temporary fix.
 

·
Registered
Joined
·
1 Posts
I have 65 with no dash lights or tail light or brake but have turn signals and reverse light. All I did was change bulbs in sail panel lights. Any suggestions
 

·
Registered
Joined
·
1,071 Posts
Dash Lights and Tail Lights both out at the same time, usually means a Fuse. Check your Fuse Box under the dash.
 
1 - 13 of 13 Posts
Top