Impalas.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I've just got my 1966 283 pg Impala running again, and I'm into the tuning and tweaking phase. I haven't rebuilt the Rochester 2GV yet, although it's obvious I should. The fast idle cam linkage is binding on the choke rod, causing poor performance when the engine is cold. Additionally, the gaskets around the base of the carb leak fuel (and vacuum?) only when the engine is cold. I think the idle circuit is blocked somewhere, as the idle mixture screws don't seem to adjust anything.

Oh, and cylinder 4 has a persistent miss :wink2:

Anyway the reason I'm posting is that the engine stalls when revving under load (like when stalling the converter) and then releasing the gas pedal. Let's say I'm attempting a burnout, revving the engine against the converter and the brakes, when I finally let off the gas, the engine stalls. Happens hot, happens cold. Park, drive, neutral, going up hills, accelerating from a stop sign and then letting off. Whenever there's a high load on the engine, and the gas is cut off, the motor just quits.

Sometimes it has trouble starting up again, like maybe the cylinders or intake are flooded.

What do you think? The easy answer is to rebuild the carb and see if it stops happening. I am planning to do that, but I've never heard of this before and I don't know what's causing it.
 

·
Premium Member
Joined
·
13,148 Posts
Welcome to the Team!

You can not adjust the idle screws because the base plate gasket has a vacuum leak. Replace the gasket to see if the idle screws are even working (if screwed in too tight you bend the tips and ream out the seat which makes fine tuning the carb next to impossible).

At this stage since your high speed idle cam is sticking and linkage is bent I would just buy a rebuilt carb at the corner parts store and use yours for a core. While there get a fresh set of points eight new plugs distributor cap and eight new plug wires. Those are the parts that keep the motor from running usually.

Big Dave
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Yeah, I think I'll just replace those gaskets. Plugs and wires couldn't hurt either. Can I find the gaskets by themselves or will I need a full rebuild kit? At that point I should just rebuild the carb.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
Do you know anything about the idle cam linkage? That linkage pivots about the choke rod on a kind of bearing or bushing, and mine seems to be sticking, preventing the choke from opening and closing properly. Is this a common problem? Is there a piece that's missing or broken? Should I replace the idle cam? I'm kinda at a loss, as everything seems to be there, yet it's getting hung up.
 

·
Premium Member
Joined
·
13,148 Posts
Probably just corroded. It is adjacent a pot metal carb body, a cast iron base plate, and aluminum rods working in a mild steel lever arm. Those metals will react to chemically over time to weld themselves together (Galvanic corrosion) that can be repaired with a Dremel tool: but it is far easier to buy a remanufactured carb. If you want the number matching original part put it in the box the rebuilt carb comes in and pay the core charge.

That way you get something you know works so that you can eliminate that source of issues from your Decision tree while doing diagnostics.

Big Dave
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Probably the best bet. I'll take it off and see if i can clean it up or sand it first, though.
 

·
Super Moderator
Joined
·
3,474 Posts
Agree on the base gasket replacement as necessary first step to help unmuddy the isolation process on the stalling.
you might get lucky with some spray cleaner and that gasket without a full rebuild.
I'd check the timing and float level too.

About that #4 miss, you might get lucky like I did and notice a spark jumping in the dark.
Also, you probably know this, make sure the inside of the distributor cap doesn't show carbon build-up or a crack.
Hopefully it's one of those two easy things or the spark plug.


Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #9 ·
About the miss... turns out my plug wires were switched... it's running a bit better now.

Working on other projects now but I'll provide updates when I get around to those gaskets.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #10 ·
Well, I rebuilt the carburetor today, and it's running TERRIBLY at idle. When I first got the carb on, it would die below 1000, but I lowered the float level and did a few tweaks and it's idling now. Cruising it's fine, but below 1000 rpm it sounds rough and bumpy, and it's only pulling 5-7" of vacuum (before it pulled 16" at idle).

I checked for vacuum leaks, and I did find that the vacuum advance line was little loose. Tightened that, no change. The only thing I can think of is that the base mounting gasket had a different pattern of slots than the original, and I had to drill some holes to make it all flow. Maybe this funky gasket is letting air go where it's not supposed to? Doesn't seem likely, as there's still no flow to the outside.

Anyway, this is my daily driver and I really want to get it back on the road before the long weekend is over :/
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #12 ·
The new gasket was wrong, causing exhaust gas from the crossover to flow into the intake. I swapped the old one back on, and now it's running at least as well as it was before. I'm gonna pick up the right gasket as soon as I can, and the idle should improve.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #13 ·
I've gotten the proper gasket, no leaks. I adjusted the accelerator pump and changed the fuel filter. I'm getting 15" vacuum in drive and 18.5" in park. There's no hesitation or stumbling, at least when the engine is warm, and it leaves hard from a stop. Still, though, she stalls if I try to do a burnout and let off the gas. Is the engine flooding? I've never heard of this happening before and I don't think it should be.
 
1 - 13 of 13 Posts
Top