Impalas.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello I have a 1966 Impala convertible in which the sway bar and links are to close to my front coil springs. When I turn or go over a bump it hits the spring and makes noise . Everything has been changed including coil springs but the sway bar is original. How can it be corrected. Thanks bobs66
 

·
Super Moderator
Joined
·
13,132 Posts
Unless you have taken everything apart and verified the GM part numbers stamped into the parts you have no way of knowing what is original (unless you bought this new back in 1966). You could also have previous collision damage or worn out to missing suspension bushings.

Big Dave
 

·
Premium Member
Joined
·
221 Posts
If it is just hitting one side, you (or someone prior) may have installed it off center. You can correct this by loosening your sway bar mounts and tapping it one direction or another with a rubber hammer.

Sway bar end links should be vertical with the car at rest. If not, you'll need to either cut them down or get longer ones to correct.
 

·
Super Moderator
Joined
·
3,407 Posts
Sounds interesting! Definitely concur on the side-to-side check and potential for adjustment.

I have an aftermarket swaybar on mine, I think it's 1 1/8th inch, but barely a sideways-finger's gap between the bar and spring on mine. Real tight.


It's feasible that your alignment is so out of whack as to cause this. eg. the Strut Rod tightened too much bringing the lower control arm forward. (?) Yeah, I'm really reaching there.

Maybe your swaybar endlinks are bent?? It's just a long bolt......easy to check.
 

·
Premium Member
Joined
·
221 Posts
Sounds interesting! Definitely concur on the side-to-side check and potential for adjustment.

I have an aftermarket swaybar on mine, I think it's 1 1/8th inch, but barely a sideways-finger's gap between the bar and spring on mine. Real tight.


It's feasible that your alignment is so out of whack as to cause this. eg. the Strut Rod tightened too much bringing the lower control arm forward. (?) Yeah, I'm really reaching there.

Maybe your swaybar endlinks are bent?? It's just a long bolt......easy to check.
Not too much of a stretch. I have 4 degrees positive caster on my 69 after replacing the control arms to accommodate. It's enough that you can spot it visually in the wheel wells.
Both the factory and the ChassisWorks (Hellwig) sway bar are close on my car. No contacting or rubbing issues though.
 

·
Registered
Joined
·
21 Posts
Do you have the correct length sway bar links?? If they are too long they hit. the center spacer should be very short. I just measured my original one: 1-1/2" spacer.
 
1 - 6 of 6 Posts
Top